Dualog Support's mailbox temporarily unavailable due to power outage
Incident Report for Dualog
Resolved
This incident has been resolved.
Posted about 1 year ago. Aug 02, 2018 - 05:49 UTC
Identified
Dualog Support's mailbox is currently unreachable due to a power outage on the hosting server. We are working on rectifying the issue.
Posted about 1 year ago. Aug 02, 2018 - 01:20 UTC
This incident affected: Support Services.