Issues routing support calls
Incident Report for Dualog
Resolved
The provider reports the issue has been resolved now.
Posted May 26, 2020 - 19:29 UTC
Update
We are continuing to monitor for any further issues.
Posted May 26, 2020 - 16:17 UTC
Monitoring
We've experienced some calls not going through properly to Dualog Support. This is due to our phone provider having issues with call routing.

Please reach out to us on email if you're having difficulties reaching our support over the phone.
Posted May 26, 2020 - 16:16 UTC
This incident affected: Support Services.